Elastix updating 2.5

From Help
Jump to: navigation, search

Elastix 2.5 is built on a very old version of CentOS that is officially EOL as of March 2017. You should be making plans to migrate to Elastix 5. However, if you really need to stick with 2.5, you will need to modify some files to be able to update your modules. CentOS has moved the updates into their vault.centos.org now, and changed the location on that server.

IMPORTANT: There will no longer be ANY more security updates, patches, etc for CentOS 5.XX. There is no "upgrade path" to move up to a newer kernel. Your organization needs to make plans ASAP to move away from this appliance platform.

Contents

Return to Main Page

Steps

It should look something like this:

[updates]
name=CentOS-$releasever - Updates
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
baseurl=http://vault.centos.org/5.11/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
exclude=redhat-logos php53*

You should now be able to update FreePBX via the Unembedded PBX Module Admin section.

Return to Top